Sylvania LD320SSX Flat screen Stuck on Standby mode

Hi, I have a Sylvania LD320SSX Flat Screen TV that is stuck on standby mode (Constant red light). I received it free from a friend who was said it would work sometimes and then be stuck in standby mode other times. I didnt see this, but when i plugged it in for first time it showed the 'video 1' icon on the screen which looked promising (I had no input at the time because we were at work). I took it home even 3 hours later and standby mode only, and it's been stuck in standby mode since. I left it unplugged for 24 hours, replugged it in and still standby mode. I have SOME multimeter skills (continuity, voltage) and am willing to YOUTUBE other suggestions as I am a tech head. The Capacitors 'look' normal, no bulges, and in fact the with the cover off most of the boards look very clean and tidy (Cover off - pics included). Mostly an experiment in learning here, I think this thing is close to working......any suggestion?
Thanx, ScreenSaver 😉

Sponsored Links
my10cents avatar
2 years ago #2
my10cents
Guru
Blogs: 60
Forum: 15,978
Votes: 114

2 boards are usually the blame--Your power Board and Your Main Board--Ironically your Power Board and Main Board are 1 piece--
You would have to acquire a schematic to trouble shoot this problem--The power board is most likely with capacitors, but that's not your problem--Check the voltage to your inverter board-- also disconnect power to backlights and turn TV on. Disconnect from Power Board side--
Let me know--

 avatar
2 years ago #3
ScreenSaver6.022x1 0/23
Guest

Hi, I checked the power to the inverter board and if I'm doing this correctly it says 170 volts DC. I checked it at the (in pic) red and black wire solder going from power board section of the main/power board heading over to inverter board. You said it should be 24 volts..is this a clue ? or did i do it wrong lol. Also, I was wondering about the 2nd suggestion to disconnect power to the backlights and turn tv on......does this mean to disconnect power to the inverter board (the same wires I checked voltage on)?
(Also, I do have the schematic pdf now)

thanx.

Sponsored Links
my10cents avatar
2 years ago #4
my10cents
Guru
Blogs: 60
Forum: 15,978
Votes: 114

What does your schematic say the output voltage should be-- I've never tested this board before but it's not that hard--
Start testing with no power to the TV--Use OHMS and diode for diodes--ohms for resistors--
The first thing you want to do is disconnect every thing from power board all flex cables-leave button board connected--Does it come on--?Also look at trouble shooting guide for you TV-
Next look into your schematic and find test voltage points, of you power board--and check them--If you run into a problem, let me know--

my10cents avatar
2 years ago #5
my10cents
Guru
Blogs: 60
Forum: 15,978
Votes: 114

You got your work cut out for you--More than likely your problem is in your power side of Power Board--Not sending proper or no voltage to your Main Board side of power board
Things to check--
1)-Capacitors--
2-)Check for 24 volts and 12 volts --
3)-Check regulator diodes-for shorts-
4)-Also check opto-coupler for short--4 pin IC from primary to secondary side-

my10cents avatar
2 years ago #6
my10cents
Guru
Blogs: 60
Forum: 15,978
Votes: 114

Start here-


Check fuses with tester set on Ohms or in diode test
Regulator diodes in diode test
Ceramic resistors in Ohms- value is on top of resistor-
Switching Mosfet-See picture below-

 avatar
2 years ago #7
ScreenSaver6.022x1 0/23
Guest

Hi, thank you for the detailed response and image explanations ...very helpful ! Thank You ! I'm going to dig in ...may take me a few days to understand the different components and how to read the Schematic 😉 I will let you know what I find...Thanx again !

Sponsored Links
my10cents avatar
2 years ago #8
my10cents
Guru
Blogs: 60
Forum: 15,978
Votes: 114

ScreenSaver6.022x1 0/23
I was wondering if you could do me a favor and run these resets on your TV to see if it will come on--Thanks--Let me know if you tried them--

1)-Unplug TV-- On TV, hold the power button down while pushing and holding each button for a few seconds. After going through all buttons, (on TV) then plug TV back in and it should power up--

2)- Unplug the power cable. Then while pressing the INPUT & VOL - buttons on the TV, plug the power cable back into the outlet (with your other hand) . When it powers up keep pressing the INPUT & VOL - after just a few seconds TV should come on--

3)-Unplug the TV and press power button 20 times, Then while plugging the TV in hold the power button in--

4)-There is one step you can take here, both as a possible fix, as well as a diagnostic evaluation
1) Unplug the power cord from the TV
2) Wait at least 1 hour (60+ Minutes)
3) Press and hold the power button (on the set, not the remote) for 60 seconds
4) Keep holding power button while plugging back in, and for another 60 seconds after. When plugging back in, go directly to the wall outlet, bypassing any power strips or surge protectors.

 avatar
1 month ago #9
T-bone
Guest

My sylvania lc320slx is suck on red only now. Need advice, Now To Remind You It Was Stuck On Green In Off Mode, But Wouldn't Come On. Need Help.

By entering this site you declare you read and agreed to its Terms, Rules & Privacy and you understand that your use of the site's content is made at your own risk and responsibility. Copyright © 2006 - 2018 DIY Forums